Lottie Header
NiMus LLC Operational Status

Incident TWO

Incident Report for NiMus LLC

Resolved

Resolved
Posted Apr 10, 2026 - 03:42 CST

Update

Status change
Posted Apr 10, 2026 - 03:41 CST

Update

We are continuing to investigate this issue.
Posted Apr 10, 2026 - 03:40 CST

Investigating

We are currently investigating this issue.
Posted Apr 09, 2026 - 23:35 CST
This incident affected: ITWO (C1I2, C2I2, C3I2, C4I2, C5I2).